Can anyone explain about Basic Switch Configuration?
campbell123 06-April-2009 01:12:05 AM

Comments


www.tech-faq.com/cisco-switch-configuration.shtml
Posted by crouse


www.bigresource.com/VB-How-do-I-switch-language-files-in-visual-basic-6-0--n5xRbz7TQs.html
Posted by crouse


A Cisco switch will function perfectly well right out of the box with no configuration required; however, it's a good idea to do a few basic configurations to personalize, secure, and optimize the device.

Setting the Hostname:
The default hostname is "Switch," which not only lacks imagination, but also is confusing if you have a lot of them. Changing the hostname is simple:

Switch(config)#hostname My2960
My2960(config)#

Notice that the hostname instantly changed!

Setting a Management IP Address:
If you want to Telnet to your switch to manage it remotely, have it participate in an SNMP system, or use the integrated HTTP server for monitoring, your switch needs an IP address and gateway address. This IP address is applied to the VLAN1 interface and the default gateway is a global command on a switch—unlike a router, a switch has no physical ports that can be assigned IP addresses, so the virtual interface of VLAN1 (the management VLAN) gets the addresses:

My2960(config)#interface vlan1
My2960(config-if)#ip address 192.168.1.2 255.255.255.0
My2960(config-if)#exit
My2960(config)#ip default-gateway 192.168.1.1

Setting Speed and Duplex on Ethernet Ports:
Although the Ethernet interfaces will auto-detect the duplex and speed setting on a 2960, it is usually a good idea to hard-code them when you are sure of what you are connecting to (such as a server, a switch, or router):

My2960(config)#interface f0/24
My2960(config-if)#speed 100
My2960(config-if)#duplex full

Serial Port Configuration:
A Cisco serial port can run several different Layer2 encapsulations—meaning, it can connect to different types of networks. You must be sure that the encapsulation type matches that of the device you are connecting to. We are interested only in three serial encapsulations: HDLC, PPP, and Frame Relay. The command to change the encapsulation is executed at the interface configuration prompt:

Router(config)#interface serial 0
Router(config-if)#encapsulation [hdlc | frame-relay | ppp]

You might also need to set up the serial speed by configuring a clock rate. Usually this is supplied by the service provider's device (the DCE—Data Communication Equipment), but in training labs we will hook a router directly to another router with a special back-to-back cable. In this situation, one of the devices must emulate the DCE, and the DCE sets the clock. Only one device needs the clock rate set.
You can also configure a bandwidth statement on the interface. This one is a little tricky; it looks like we are setting the bandwidth (as in bits per second) of the interface, but we really aren't—the clock rate sets the physical data rate. What we are doing with the bandwidth command is reporting to the routing protocols about the capacity of the interface. It might have an actual clock rate of 64000 (64K), but we could lie and set the bandwidth to 56K for the purposes of routing information:

Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 56

Enabling Interfaces:
By default, every interface on a router (whether it is brand new or has had its configuration erased) is in a shutdown state. This is also known as administratively down; although the interface might have been perfectly configured with an IP and mask, encapsulation, and whatever else is needed, the interface is effectively off—even Layer 1 is down. A shutdown interface doesn't send or receive any data at all, and it causes the other end of a serial link to think it is dead altogether. So when you first configure a new router or one that has had its configuration erased, remember to issue the no shutdown command at each interface, or none of the interfaces will work!

Router(config-if)#no shutdown

On a router, every interface is a gateway to another network. For this reason, we do not need to supply a default gateway. However, every interface you intend to use will need an IP address and mask. The commands to set an IP are exactly the same as on a switch. Don't forget the no shutdown (no shut for short):

Router(config)#interface s0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#interface e0
Router(config-if)#ip address 172.16.0.1 255.255.0.0
Router(config-if)#no shut
Posted by thomas


Please visit:

www.tech-faq.com/cisco-switch-configuration.shtml
Posted by sagitraz



Posted: 06-April-2009 03:31:30 AM By: sagitraz

Please visit:

www.tech-faq.com/cisco-switch-configuration.shtml

Posted: 07-April-2009 01:02:08 AM By: thomas

A Cisco switch will function perfectly well right out of the box with no configuration required; however, it's a good idea to do a few basic configurations to personalize, secure, and optimize the device.

Setting the Hostname:
The default hostname is "Switch," which not only lacks imagination, but also is confusing if you have a lot of them. Changing the hostname is simple:

Switch(config)#hostname My2960
My2960(config)#

Notice that the hostname instantly changed!

Setting a Management IP Address:
If you want to Telnet to your switch to manage it remotely, have it participate in an SNMP system, or use the integrated HTTP server for monitoring, your switch needs an IP address and gateway address. This IP address is applied to the VLAN1 interface and the default gateway is a global command on a switch—unlike a router, a switch has no physical ports that can be assigned IP addresses, so the virtual interface of VLAN1 (the management VLAN) gets the addresses:

My2960(config)#interface vlan1
My2960(config-if)#ip address 192.168.1.2 255.255.255.0
My2960(config-if)#exit
My2960(config)#ip default-gateway 192.168.1.1

Setting Speed and Duplex on Ethernet Ports:
Although the Ethernet interfaces will auto-detect the duplex and speed setting on a 2960, it is usually a good idea to hard-code them when you are sure of what you are connecting to (such as a server, a switch, or router):

My2960(config)#interface f0/24
My2960(config-if)#speed 100
My2960(config-if)#duplex full

Serial Port Configuration:
A Cisco serial port can run several different Layer2 encapsulations—meaning, it can connect to different types of networks. You must be sure that the encapsulation type matches that of the device you are connecting to. We are interested only in three serial encapsulations: HDLC, PPP, and Frame Relay. The command to change the encapsulation is executed at the interface configuration prompt:

Router(config)#interface serial 0
Router(config-if)#encapsulation [hdlc | frame-relay | ppp]

You might also need to set up the serial speed by configuring a clock rate. Usually this is supplied by the service provider's device (the DCE—Data Communication Equipment), but in training labs we will hook a router directly to another router with a special back-to-back cable. In this situation, one of the devices must emulate the DCE, and the DCE sets the clock. Only one device needs the clock rate set.
You can also configure a bandwidth statement on the interface. This one is a little tricky; it looks like we are setting the bandwidth (as in bits per second) of the interface, but we really aren't—the clock rate sets the physical data rate. What we are doing with the bandwidth command is reporting to the routing protocols about the capacity of the interface. It might have an actual clock rate of 64000 (64K), but we could lie and set the bandwidth to 56K for the purposes of routing information:

Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 56

Enabling Interfaces:
By default, every interface on a router (whether it is brand new or has had its configuration erased) is in a shutdown state. This is also known as administratively down; although the interface might have been perfectly configured with an IP and mask, encapsulation, and whatever else is needed, the interface is effectively off—even Layer 1 is down. A shutdown interface doesn't send or receive any data at all, and it causes the other end of a serial link to think it is dead altogether. So when you first configure a new router or one that has had its configuration erased, remember to issue the no shutdown command at each interface, or none of the interfaces will work!

Router(config-if)#no shutdown

On a router, every interface is a gateway to another network. For this reason, we do not need to supply a default gateway. However, every interface you intend to use will need an IP address and mask. The commands to set an IP are exactly the same as on a switch. Don't forget the no shutdown (no shut for short):

Router(config)#interface s0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#interface e0
Router(config-if)#ip address 172.16.0.1 255.255.0.0
Router(config-if)#no shut

Posted: 07-April-2009 12:34:07 PM By: crouse

www.bigresource.com/VB-How-do-I-switch-language-files-in-visual-basic-6-0--n5xRbz7TQs.html

Posted: 07-April-2009 12:45:14 PM By: crouse

www.tech-faq.com/cisco-switch-configuration.shtml